Information & Formation Index du Forum
Information & Formation Index du ForumFAQRechercherS’enregistrerConnexion



 ILEIC forum 
Exercice Windev

 
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net
Sujet précédent :: Sujet suivant  
Auteur Message
hankach
Administrateur

Hors ligne

Inscrit le: 23 Mar 2007
Messages: 133
Point(s): 144
Moyenne de points: 1,08

MessagePosté le: Mer 10 Nov - 11:04 (2010)    Sujet du message: Exercice Windev Répondre en citant


Exercice traitement Conditionnelle

Soit à calculer le prix et le montant d’une opération de location d’une voiture et à la lumière des informations ci-dessous

Marque Type prix
Fiat
E 200
D 150
Peugeot
E 300
D 350
DACIA
E 250
D 300




Solution

==============================================================================
Clic sur nouveau
==============================================================================
RAZ(1)
EcranPremier(s1)
==============================================================================
Enter de s3
==============================================================================
i est un entier
i=ListeSelect(c1)
SI i=1 ET tp[1]=1 ALORS
s3=200
SINON
SI i=1 ET tp[2]=1 ALORS
s3=150
SINON
SI i=2 ET tp[1]=1 ALORS
s3=300
SINON
SI i=2 ET tp[2]=1 ALORS
s3=350
SINON
SI i=3 ET tp[1]=1 ALORS
s3=250
SINON
s3=300
FIN
FIN
FIN
FIN
FIN

==============================================================================
Clic sur ajouter
==============================================================================
type est un chaîne
mt est un réel
SI tp[1]=1 ALORS
type="E"
SINON
type="D"
FIN
mt=s3*s4
TableAjoute(table1,s1+TAB+c1[c1]+TAB+type+TAB+s2+TAB+s3+TAB+s4+TAB+mt)

==============================================================================
Clic sur recherche
==============================================================================
p est un entier
p=TableCherche(table1.COL_Matricule,s1)
SI p=-1 ALORS
Erreur("matrucule introvable")
SINON
TableSelectPlus(table1,p)
Modifier..Etat=Actif
FIN
==============================================================================
Clic sur supprimer
==============================================================================

TableSupprime(table1,ListeSelect(table1))

==============================================================================
Clic sur modifier
==============================================================================

type est un chaîne
mt est un réel
i est un entier
i=ListeSelect(c1)
SI i=1 ET tp[1]=1 ALORS
s3=200
SINON
SI i=1 ET tp[2]=1 ALORS
s3=150
SINON
SI i=2 ET tp[1]=1 ALORS
s3=300
SINON
SI i=2 ET tp[2]=1 ALORS
s3=350
SINON
SI i=3 ET tp[1]=1 ALORS
s3=250
SINON
s3=300
FIN
FIN
FIN
FIN
FIN
TableModifie(table1,s1+TAB+c1[c1]+TAB+type+TAB+s2+TAB+s3+TAB+s4+TAB+mt)
Modifier..Etat=Grisé

==============================================================================
Clic sur quitter
==============================================================================
FinProgramme

_________________
Tous ce que vous faites pour moi sans moi vous le faite contre moi


Revenir en haut
Publicité






MessagePosté le: Mer 10 Nov - 11:04 (2010)    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net Toutes les heures sont au format GMT + 1 Heure
Page 1 sur 1

 
Sauter vers:  

Index | Panneau d’administration | créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Template zenGarden created by larme d'ange
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com