Information & Formation Index du Forum
Information & Formation Index du ForumFAQRechercherS’enregistrerConnexion



 ILEIC forum 
Exercice Windev

 
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net
Sujet précédent :: Sujet suivant  
Auteur Message
hankach
Administrateur

Hors ligne

Inscrit le: 23 Mar 2007
Messages: 133
Point(s): 144
Moyenne de points: 1,08

MessagePosté le: Jeu 11 Nov - 21:41 (2010)    Sujet du message: Exercice Windev Répondre en citant

Traitement conditionnel :

  Exercice


  
On cherche à calculer, pour un client, le montant net (MTN) d’une facture sachons que :  Le montant net (MTN) :
MTN=MHT – RM – RD
La remise  (RM):
  
Montant hors taxe MHT
Taux de remise TRM
≥20 000
15%
[10 000 – 20 000[
10%
< 10 000
5%

RM=MHT * TRM
La réduction RD :
  
Catégorie
Taux de réduction
A
5%
B
2%
C
1%
  
 

   


Solution


  
               Clic sur nouveau RAZ()
                EcranPremier(s1)

               ===================================
               Clic sur Calculer
 
             // Cacul de la Remise :
              TRM est un réel
 
             SI s2>=20 000 ALORS
              trm=15/100
              SINON
            SI s2>=10 000 ALORS
             trm=10/100
             SINON
                    trm=5/100
                    FIN
             FIN
           s3=s2*trm
           // Calcule de la réduction
          Trd est un réel
          n est un entier
         n=ListeSelect(c1)
          SI n= 1 ALORS
          trd=5/100
         SINON
         SI n=2 ALORS
             trd=2/100
             SINON
             trd=1/100
          FIN
         FIN
         s4=s2*Trd
         s5=s2-s3-s4
         =======================================
          Clic sur fermer
          SI OuiNon("voulez vous quitter?")=1 ALORS
          FinProgramme
         FIN
_________________
Tous ce que vous faites pour moi sans moi vous le faite contre moi


Revenir en haut
Publicité






MessagePosté le: Jeu 11 Nov - 21:41 (2010)    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net Toutes les heures sont au format GMT + 1 Heure
Page 1 sur 1

 
Sauter vers:  

Portail | Index | Panneau d’administration | créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Template zenGarden created by larme d'ange
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com