Information & Formation Index du Forum
Information & Formation Index du ForumFAQRechercherS’enregistrerConnexion



 ILEIC forum 
exercice windev 3

 
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net
Sujet précédent :: Sujet suivant  
Auteur Message
hankach
Administrateur

Hors ligne

Inscrit le: 23 Mar 2007
Messages: 133
Point(s): 144
Moyenne de points: 1,08

MessagePosté le: Ven 26 Nov - 21:57 (2010)    Sujet du message: exercice windev 3 Répondre en citant

Exercice 3 
Traitement conditionnel 
Manipulation de l’objet table 
  
Soit à calculer pour un stagiaire  la décision et la Mention  sachons que : 
 
Soit à calculer pour un stagiaire  la décision et la Mention  sachons que : 
décision 
Moyenne 
Décision 
≥ 10 
Admis 
< 10 
Echec 

Mention 
Moyenne 
Décision 
≥ 16 
Très bien 
[14-16[ 
Bien 
[12-14[ 
Assez bien 
[10-12[ 
Passable 
< 10 
Médiocre 

                                                                     Voir  l’interface ci-dessous :







Clic sur nouveau
RAZ(1)
 
Clic sur  Calculer
my est un real
my =s2
SI my >=16 ALORS
       s4= "T.bien"
SINON
       SI my>= 14 ALORS
             s4="Bien"
       SINON
             SI my >=12 ALORS
                    s4 = "A.bien"
             SINON
                    SI my>= 10 ALORS
                           s4= "Passable"
                    SINON
                           s4= "Faible"
                          
                    FIN
             FIN
       FIN
FIN
SI my >=10 ALORS
       s3= "Admis"
SINON
       s3= "Echec"
      
FIN
 
Clic sur   ajouter
 
TableAjoute(Table1,s1+TAB+c1+TAB+s2+TAB+s3+TAB+s4)
 
Clic sur chercher
p est un entier
p = TableCherche(Table1.COL_Code,s1)
SI p = -1 ALORS
       Info("code ourilla")
SINON
       TableSelectPlus(Table1,p)
       s1=Table1.COL_Code
       c1=Table1.COL_Filiere
       s2=Table1.COL_Moyenne
       s3=Table1.COL_Décision
       s4=Table1.COL_Mention
      
      
FIN
 
Clic sur modifier
 
 
TableModifie(Table1,s1+TAB+c1+TAB+s2+TAB+s3+TAB+s4)
 
Clic sur Supprimer
 
TableSupprime(Table1,TableSelect(Table1))
 
Clic sur Effacer
 
TableSupprimeTout(Table1)


 
 


_________________
Tous ce que vous faites pour moi sans moi vous le faite contre moi

Revenir en haut
Publicité






MessagePosté le: Ven 26 Nov - 21:57 (2010)    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net Toutes les heures sont au format GMT + 1 Heure
Page 1 sur 1

 
Sauter vers:  

Portail | Index | Panneau d’administration | créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Template zenGarden created by larme d'ange
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com