Information & Formation Index du Forum
Information & Formation Index du ForumFAQRechercherS’enregistrerConnexion



 ILEIC forum 
Exercie 4

 
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net
Sujet précédent :: Sujet suivant  
Auteur Message
hankach
Administrateur

Hors ligne

Inscrit le: 23 Mar 2007
Messages: 133
Point(s): 144
Moyenne de points: 1,08

MessagePosté le: Lun 29 Nov - 11:04 (2010)    Sujet du message: Exercie 4 Répondre en citant

Exercice 
Soit à éditer les bulletins des stagiaires selon l’interface ci-dessous et à la lumière des informations  annexe 1 

 

 

 

 

 

 

 
 
Annexe1
 
Moyenne générale = total moyenne_unité /total cœfficient
Décision
 
 
Moyenne
Décision
≥ 10
Admis
<10
Echec

 
 
 
Mention
 
Moyenne
Mention
≥ 16
Très bien
[14 – 16[
Bien
[12- 14[
Assez bien
[10 – 12[
Passable
<10
Médiocre
 

 

 

 

 

 
 
Solution 
Clic sur Nouveau
RAZ(1)
EcranPremier(s1)
 
Clic sur Calculer
p est un entier
s8=0
s9=0
POUR p=1 A TableOccurrence(table1)
      
       s8=s8+table1.COL_Cof[p]
       s9=s9+table1.COL_Moy_unité[p]
      
FIN
s10=s9/s8
 SI s10>=10 ALORS
       s11="admine"
       SINON
             s11="Echec"
            
 FIN
 SI s10>=16 ALORS
       s12="t.bien"
       SINON
       SI s10>=14 ALORS
                    s12="bien"
                    SINON
             SI s10>=12 ALORS
                           s12="abien"
                                  SINON
                    SI s10>=10 ALORS
                                  s12="passable"
                                        SINON
                                        s12="febele"
                    FIN
             FIN
       FIN         
 FIN
 
Clic sur Fermer
SI OuiNon(" quitter ")=2 ALORS
       FinProgramme
FIN
 
Clic sur Ajouter
myu est un réel
myu=s6*s7
p est un entier
p=TableCherche(table1.COL_Code_unité,s4)
SI p=-1 ALORS
       TableAjoute(table1,s4+TAB+s5+TAB+s7+TAB+s6+TAB+myu)
SINON
       Info("code unite exsite deja")
       s4=""
       RepriseSaisie(s4)
      
      
FIN
 
Clic sur Rechercher
p est un entier
p=TableCherche(table1.COL_Code_unité,s4)
SI p=-1 ALORS
       Erreur("code unité introvable")
       SINON
       TableSelectPlus(table1,p)
       s4=table1.COL_Code_unité
       s5=table1.COL_Unité
       s6=table1.COL_Cof
       s7=table1.COL_Note
       modifier..Etat=Actif
       FIN
 
Clic Modifier
Myu est un réel
myu=s6*s7
TableModifie(table1,s4+TAB+s5+TAB+s7+TAB+s6+TAB+myu)
modifier..Etat=Grisé
 
Clic supprimer
SI OuiNon("êtes-vous sur de vouloir supprimer la ligne sélectionnée")=1 ALORS
TableSupprime(table1,TableSelect(table1))
FIN
 
 
 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

_________________
Tous ce que vous faites pour moi sans moi vous le faite contre moi


Revenir en haut
Publicité






MessagePosté le: Lun 29 Nov - 11:04 (2010)    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net Toutes les heures sont au format GMT + 1 Heure
Page 1 sur 1

 
Sauter vers:  

Portail | Index | Panneau d’administration | créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Template zenGarden created by larme d'ange
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com