Information & Formation Index du Forum
Information & Formation Index du ForumFAQRechercherS’enregistrerConnexion



 ILEIC forum 
Fonctions standard de Windev

 
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net
Sujet précédent :: Sujet suivant  
Auteur Message
hankach
Administrateur

Hors ligne

Inscrit le: 23 Mar 2007
Messages: 133
Point(s): 144
Moyenne de points: 1,08

MessagePosté le: Mer 8 Déc - 11:09 (2010)    Sujet du message: Fonctions standard de Windev Répondre en citant

Fonctions standard de Windev 
  Fonction mathématique
 
Fonctions de base
Abs
Calcule la valeur absolue d'une expression numérique ou d'une expression numérique (entière ou réelle)
Arrondi
Calcule la valeur arrondie d'une valeur numérique selon le nombre de décimales précisé
EstImpair
Identifie un nombre impair
EstPair
Identifie un nombre pair
Max
Renvoie la plus grande des valeurs passées en paramètre
Min
Renvoie la plus petite des valeurs passées en paramètre
PartieDécimale
Renvoie la partie décimale d'un nombre
PartieEntière
Renvoie la partie entière d'un nombre
Puissance
Élève un nombre à une puissance
Racine
Calcule la racine d'un nombre
 
  Exercice 1
Soit à remplir les deux tables, ci-dessous (table1 et table2), avec des Entiers paires et impaires respectivement (compris entre 0 et 30) ensuite calculer pour chaque table les valeurs Maximum, minimum et moyenne comme indiqué sur la fenêtre suivante :












 
Ecrire le traitement lié au bouton
Pour
 
Remplir table1
Remplir la table1 avec des nombres pairs compris entre 0 et 30
Remplir table2
Remplir la table2 avec des nombres impairs compris entre 0 et 30
Calculer 1
Calculer pour table 1 les valeurs Maximum, minimum et moyenne
Calculer 1
Calculer pour table 1 les valeurs Maximum, minimum et moyenne
 


 
Solution 
 
Clic sur Remplir_table1
i est un entier
 
TableSupprimeTout(Table1)
 
POUR i=1 A 30
SI EstPair(i)=1 ALORS
       TableAjoute(Table1,i)
       FIN
FIN
Clic sur calculer1
// Nombres Paires  ================================================
mn,mx, tl sont des réels
i est un entier
tl=0
mx=Table1.COL_Nobres_Paires[1]
mn=Table1.COL_Nobres_Paires[1]
POUR i=1 A TableOccurrence(Table1)
       mx=Max(mx,Table1.COL_Nobres_Paires[i])
       mn=    Min(mn,Table1.COL_Nobres_Paires[i])
       tl=tl+Table1.COL_Nobres_Paires[i]
FIN
s1=mx
s2=mn
s3=tl/TableOccurrence(Table1)
 
Clic sur Remplir_table1
j est un entier
 
 
TableSupprimeTout(Table2)
POUR j=1 A 30
       SI EstImpair(j)=1 ALORS
             TableAjoute(Table2,j)
       FIN
FIN
 
Clic sur calculer1
// Nombres Impaires  ================================================
mn1,mx1, tl1 sont des réels
i est un entier
tl1=0
mx1=Table2.COL_Nombres_Impaires[1]
mn1=Table2.COL_Nombres_Impaires[1]
POUR i=1 A TableOccurrence(Table2)
       mx1=Max(mx1,Table2.COL_Nombres_Impaires[i])
       mn1=   Min(mn1,Table2.COL_Nombres_Impaires[i])
       tl1=tl1+Table2.COL_Nombres_Impaires[i]
FIN
s11=mx1
s22=mn1
s33=tl1/TableOccurrence(Tabl
 
 

_________________
Tous ce que vous faites pour moi sans moi vous le faite contre moi


Revenir en haut
Publicité






MessagePosté le: Mer 8 Déc - 11:09 (2010)    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Information & Formation Index du Forum -> Espace Informatiques -> Développement informatique -> Basic/Windev et les .Net Toutes les heures sont au format GMT + 1 Heure
Page 1 sur 1

 
Sauter vers:  

Index | Panneau d’administration | créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Template zenGarden created by larme d'ange
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com